archive: July 2009

25
JUL
2009

As a contributing developer to the WordPress code base, I find it very hard to operate now a days to get WordPress to do more functionally with keeping in mind that it was to work on at least PHP 4.3.0. Right now only 10 to 15% of the code is true object based code. Most of it having to do with quires to the database.

What is the problem with PHP 4.3.0?  PHP 4.3.0 through versions of PHP 5.2.9 is not supported anymore. This creates a number of issues in dealing with security issues. 3/4 of the worlds blogs are now WordPress. A lot of potential holes.

It’s not official yet that WordPress 3.0 be only PHP 5.3.0+. I am going to try to bring this to the developer meeting this next Thursday, July 30th, 2009.

Comments 0

Commenting is closed

No Comments Yet